Service Disruption
Resolved
May 14, 2026 at 2:57pm UTC
Everything is back up and running, including the dashboard.
We’re really sorry for the long wait and the disruption this caused. We know how important these services are, and we appreciate you sticking with us while we worked to fix things.
Our team is continuing to monitor closely to make sure everything stays stable. Thanks again for your patience
Affected services
Updated
May 13, 2026 at 3:15pm UTC
We have restored API functionality, and it is now operating normally.
Our dashboard platform is still undergoing maintenance as we continue remediation efforts. We’ll provide further updates as progress continues.
Affected services
Created
May 13, 2026 at 11:54am UTC
We are currently responding to a critical infrastructure issue affecting our API and dashboard platform. Services are temporarily unavailable while remediation and recovery efforts are underway.
Affected services